A great new UI refresh and significant new functionality is here!
See the 2.10 Release Notes for details.

ConnectALL Server Hardware and Software Requirements

Below are the hardware and software requirements to install the ConnectALL server.  

Hardware Requirements

  1. Server with Linux or MS Windows 2003 / 2008 / 2012 / 2016 / 2019

  2. Minimum Dual Core 3 GHz CPU (recommended 4 Core 3 GHz)

  3. Minimum 4 GB RAM if just Tomcat and Mule (recommended  8 GB, regardless)

  4. Minimum 30 GB hard drive and a database server (MySql / MS SQL Server / Oracle / Postgresql)

  5. Admin privileges on the server


Info

The ConnectALL 2.9 install package includes MuleSoft 3.9.0 and JDK 8.  To use MuleSoft 3.9.0 please use the ConnectALL Installer Version >= 2.9.0.

Software Supported 

ConnectALL Versions up to 2.8.x

  1. Oracle Java 7 & 8 
  2. Tomcat 6, 7 & 8
  3. MuleSoft 3.6.1
  4. One of the following databases must be pre-installed:
    1. Mysql 5.7.24
    2. MS-SQL 2005, 2008 and 2012. 
    3. Oracle 11g
    4. Postgresql 11.4 (8.3 works when "IF NOT EXISTS” clause on the CREATE statements are removed from the setup_postgresql.sql file)

ConnectALL Version 2.9.0 onwards

  1. Oracle Java 8 and AdoptOpenJDK
  2. Tomcat 7 & 8
  3. MuleSoft 3.9.0
  4. One of the following databases must be pre-installed:
    1. Mysql 5.7.24
    2. MS-SQL 2005, 2008, 2012, 2016 and 2017. 
    3. Oracle 11g
    4. Postgresql 11.4 (8.3 works when "IF NOT EXISTS” clause on the CREATE statements are removed from the postgres.sql file)


ConnectALL is managed through a web browser interface. ConnectALL is optimized for Chrome and Firefox. While we endeavor to ensure that ConnectALL also works on IE, for the best experience, use either of the other browsers.